Available in: Axsy Field Service
Problem
After installing an upgrade to the Axsy Managed Package, push notifications to the mobile apps stop working.
Root Cause
Notifications require a Salesforce custom setting to be enabled for push notifications to work. Occasionally this setting is not enabled after a Managed Package upgrade.
Resolution
Step 1
- Locate and select Custom Settings from Salesforce Setup
- From the list of Custom Settings click on Axsy FSL Mobile
Figure 1 – Custom Settings
Step 2
- From the Custom Setting Definition for Axsy FSL Mobile, select Manage
Figure 2 – Custom Settings Definition
Step 3
- Next, check to see if the Axsy FSL Mobile Setting is absent or present, check Figures 3 and 4 to verify which applies to your case.
Figure 3 – Axsy FSL Mobile Custom Settings Absent
Figure 4 – Axsy FSL Mobile Custom Settings Present
If you do not have a custom setting for Axsy FSL as shown in Figure 3, then continue with the remainder of the steps in this FAQ.
If you do have a custom setting as shown in Figure 4, then push notifications should be working, please verify by assigning a Service Appointment to a user.
Step 4
- With reference to Figure 3, click New
- From the Axsy FSL Mobile Edit screen, click Save (do not make any changes)
Figure 5 – Axsy FSL Mobile Edit Screen
Step 5
- Navigate back to show Figure 4 to confirm the Axsy FSL Mobile Custom Settings are present
- Push notifications should now be working, please verify by assigning a Service Appointment to a user.